Back to overview
Resolved

kappesante.com and kingrus.co are down

Jun 8, 2026 at 1:11pm UTC
Affected services
kingrus.co

Resolved
Jun 8, 2026 at 1:11pm UTC

kingrus.co recovered.